Changing Magnus Box's temporary directory
Magnus Box uses the local system's temporary directory for some cache files while the backup job is running. The needed storage size is small; but on some devices (e.g. NAS with fixed-size /tmp/ mounts) the system's default temporary directory may be insufficient.
On Linux, you can change the temporary directory Magnus Box uses by adding export TMPDIR=/some/other/path/ in your startup script (e.g. normally /opt/MagnusBox/backup-daemon-start.sh or any custom rc.local file). However, any changes to the backup-daemon-start.sh file will be overwritten by Magnus Box software updates.
On a NAS (for example Synology or QNAP), or if a Linux backup fails with "no space left on device", follow the step-by-step instructions in NAS Error: "no space left on device". It covers changing the temporary directory over SSH or with a one-time backup command.
On macOS, you can change the temporary directory Magnus Box uses by adding an EnvironmentVariables section to the backup.delegate.plist LaunchDaemon. However, any changes to the .plist file will be overwritten by Magnus Box software updates.
On Windows, you can change the temporary directory Magnus Box uses by
- setting the
%TMP%or%TEMP%environment variables for theNT SERVICE\backup.delegateuser account; or - modifying the
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\backup.delegate\Parameters\AppEnvironmentExtraregistry key to addTEMP=C:\some\pathon a new line, and, restarting thebackup.delegateservice
Related articles
- NAS Error: "no space left on device" (NAS steps)